Il forum ci mette molto a caricare il latex

Cosa ti piace e cosa non ti piace nel sito? Proponi le tue modifiche!

Moderatore: tutor

Avatar utente
domx
Messaggi: 405
Iscritto il: 05 dic 2010, 17:21
Contatta:

Il forum ci mette molto a caricare il latex

Messaggioda domx » 12 dic 2010, 19:45

Ciao a tutti, da due o tre giorni il forum a me sta impiegando più del solito a caricare le formule in LaTeX. Succede anche a voi? Sarà una cosa passeggera?
Ciao e grazie ;)

Avatar utente
domx
Messaggi: 405
Iscritto il: 05 dic 2010, 17:21
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda domx » 16 dic 2010, 18:45

Possibile succeda solo a me?

staffo
Messaggi: 305
Iscritto il: 01 mar 2010, 15:34

Re: Il forum ci mette molto a caricare il latex

Messaggioda staffo » 16 dic 2010, 19:19

nono, anche a me ci mette molto, per pagine molto lunghe anche un paio di minuti, per pagine con due o tre formule arriva anche a 20 secondi. mi sembra tanto, no?
[tex]\Lambda \eta \delta r \epsilon \alpha[/tex]

Avatar utente
ndp15
Messaggi: 598
Iscritto il: 18 gen 2007, 19:01
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda ndp15 » 16 dic 2010, 19:38

A me impiega moltissimo con firefox (v. 3.6.13), rimane lento ma già più accettabile con explorer (v. 8) mentre carica tutto con ottime prestazioni con Chrome (v. 8).
Siccome però utilizzo abitualmente firefox spero (e sono fiducioso) che si stia lavorando per ottimizzare le prestazioni.

staffo
Messaggi: 305
Iscritto il: 01 mar 2010, 15:34

Re: Il forum ci mette molto a caricare il latex

Messaggioda staffo » 16 dic 2010, 20:18

ecco, anche io uso solo firefox, stessa dua versione o similia, quindi credo sia quello il problema, tutti gli altri browser a mio parere sono obsoleti!

però per il LaTeX è davvero snervante aspettare così tanto.
[tex]\Lambda \eta \delta r \epsilon \alpha[/tex]

Veluca
Messaggi: 185
Iscritto il: 27 dic 2008, 01:08
Località: Chiavari (Genova)

Re: Il forum ci mette molto a caricare il latex

Messaggioda Veluca » 16 dic 2010, 23:05

È un bug noto di mathjax con la versione 3.6.13 di firefox che è già stato sistemato nella versione ufficiale: richiede l'aggiornamento dei font html+css sul server (cosa che in realtà impiega 10 minuti)
Io non ho problemi di questa natura perchè uso firefox 4 (b9pre, daily build) e nonostante il mio PentiumD dell'altro millennio (ok non esageriamo...) riesco a visualizzare tutto in tempi accettabilissimi :P
L'altra soluzione sarebbe installare in locale alcuni font, non ricordo quali ma cercando sul sito di mathjax si trova
PS: @chi pensa che gli altri browser siano obsoleti rispetto a firefox 3.. aspettate di vedere il 4 :P
PPS: domx ma tu sei quello che sta su ubuntuforums col tuo stesso nickname? se è così, prova il ppa con le daily di ff, meritano parecchio e sono (abbastanza) stabili

staffo
Messaggi: 305
Iscritto il: 01 mar 2010, 15:34

Re: Il forum ci mette molto a caricare il latex

Messaggioda staffo » 16 dic 2010, 23:15

per installare i fonts come faccio? comunque mi sa che faccio partire l'aggiornamento di firefox proprio ora.
[tex]\Lambda \eta \delta r \epsilon \alpha[/tex]

Veluca
Messaggi: 185
Iscritto il: 27 dic 2008, 01:08
Località: Chiavari (Genova)

Re: Il forum ci mette molto a caricare il latex

Messaggioda Veluca » 17 dic 2010, 00:57

che io sappia devi scaricare il file zip da qui http://www.stixfonts.org/ poi lo estrai e copi i vari files dalla cartella Fonts in:
- se usi windows, C:\Windows\Fonts (almeno era così su XP)
- se usi linux, in ~/.fonts oppure in /usr/share/fonts

staffo
Messaggi: 305
Iscritto il: 01 mar 2010, 15:34

Re: Il forum ci mette molto a caricare il latex

Messaggioda staffo » 17 dic 2010, 06:47

grazie, peerchè ho messo la 4 beta 7 di firefox, e lì funziona bene, però uso ancora l'altro molte volte perchè avevo un po' di componenti aggiuntivi e non tutti mi funzionano qui
[tex]\Lambda \eta \delta r \epsilon \alpha[/tex]

fph
Site Admin
Messaggi: 3152
Iscritto il: 01 gen 1970, 01:00
Località: in giro
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda fph » 17 dic 2010, 10:15

Veluca ha scritto:...richiede l'aggiornamento dei font html+css sul server (cosa che in realtà impiega 10 minuti)

...e cosa che il nostro webmaster dovrebbe avere già fatto qualche giorno fa. :?:
Sapete se c'è qualche modo di controllare se è stato fatto l'aggiornamento?
--federico
[tex]\frac1{\sqrt2}\bigl(\left|\text{loves me}\right\rangle+\left|\text{loves me not}\right\rangle\bigr)[/tex]

Avatar utente
domx
Messaggi: 405
Iscritto il: 05 dic 2010, 17:21
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda domx » 17 dic 2010, 14:59

Veluca ha scritto:PPS: domx ma tu sei quello che sta su ubuntuforums col tuo stesso nickname? se è così, prova il ppa con le daily di ff, meritano parecchio e sono (abbastanza) stabili

sì, tu chi sei lì? :D
comunque ho risolto facendo come hai detto nel post successivo, ora non li carica seduta stante, ma ci mette al massimo due secondi, quindi è perfetto così, grazie ;)

fph
Site Admin
Messaggi: 3152
Iscritto il: 01 gen 1970, 01:00
Località: in giro
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda fph » 17 dic 2010, 17:02

domx ha scritto:comunque ho risolto facendo come hai detto nel post successivo

Link plz :)
--federico

[tex]\frac1{\sqrt2}\bigl(\left|\text{loves me}\right\rangle+\left|\text{loves me not}\right\rangle\bigr)[/tex]

Avatar utente
ndp15
Messaggi: 598
Iscritto il: 18 gen 2007, 19:01
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda ndp15 » 17 dic 2010, 17:05

fph ha scritto:
domx ha scritto:comunque ho risolto facendo come hai detto nel post successivo

Link plz :)

Direi: viewtopic.php?p=130821#p130821

Avatar utente
domx
Messaggi: 405
Iscritto il: 05 dic 2010, 17:21
Contatta:

Re: Il forum ci mette molto a caricare il latex

Messaggioda domx » 17 dic 2010, 17:38

ndp15 ha scritto:
fph ha scritto:
domx ha scritto:comunque ho risolto facendo come hai detto nel post successivo

Link plz :)

Direi: viewtopic.php?p=130821#p130821

esatto ;)

Nabir Albar
Messaggi: 62
Iscritto il: 22 nov 2010, 19:09
Località: Sto ca... Stoccarda!

Re: Il forum ci mette molto a caricare il latex

Messaggioda Nabir Albar » 17 dic 2010, 19:50

Io ho ancora problemi, cmq può darsi che l'aggiornamento non sia ancora stato fatto:
ho salvato qualche font che scarica Firefox (per esempio http://www.oliforum.it/MathJax/fonts/HTML-CSS/TeX/otf/MathJax_Math-Italic.otf) e sono diversi da quelli nuovi sul sito di MathJax.. :o


Torna a “Il sito delle olimpiadi della matematica”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite